summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2019-11-22 20:37:30 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-02-17 23:16:43 +0100
commite7c7326873b9d4f9c45d77cf4ad2ec370d4f00da (patch)
tree6dc6035897144a858991c7a012a05080b8a54336 /gnu/packages/commencement.scm
parentfa638c18b61db9b9340c35f54f8438d6fabe352b (diff)
downloadguix-e7c7326873b9d4f9c45d77cf4ad2ec370d4f00da.tar.gz
gnu: commencement: Add binutils-mesboot1.
* gnu/packages/commencement.scm (binutils-mesboot1): New variable.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 4633051fc7..eb43356665 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1731,6 +1731,32 @@ ac_cv_c_float_format='IEEE (little-endian)'
                (symlink "grep" (string-append bin "/fgrep"))
                #t))))))))
 
+(define binutils-mesboot1
+  (package
+    (inherit binutils-mesboot0)
+    (name "binutils-mesboot1")
+    (native-inputs (%boot-mesboot0-inputs))
+    (arguments
+     (substitute-keyword-arguments (package-arguments binutils-mesboot0)
+       ((#:configure-flags configure-flags)
+        '(let ((out (assoc-ref %outputs "out")))
+           `("--disable-nls"
+             "--disable-shared"
+             "--disable-werror"
+             "--build=i686-unknown-linux-gnu"
+             "--host=i686-unknown-linux-gnu"
+             "--with-sysroot=/"
+             ,(string-append "--prefix=" out))))
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (replace 'setenv
+             (lambda _
+               (let* ((out (assoc-ref %outputs "out"))
+                      (bash (assoc-ref %build-inputs "bash"))
+                      (shell (string-append bash "/bin/bash")))
+                 (setenv "CONFIG_SHELL" shell)
+                 #t)))))))))
+
 (define binutils-mesboot
   (package
     (inherit binutils-mesboot0)