summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-03-07 16:57:20 +0100
committerLudovic Courtès <ludo@gnu.org>2018-03-07 21:39:32 +0100
commit0fccb24765dfda3e90d7ce6981d9204f05aa6117 (patch)
tree426715ace084a1c6a38c0c717ab636c39c45b80f /gnu/packages/commencement.scm
parent021caafa2cd213f773386af8a3226a4ad41683da (diff)
downloadguix-0fccb24765dfda3e90d7ce6981d9204f05aa6117.tar.gz
gnu: commencement: 'glibc-final' now inherits from 'glibc'.
* gnu/packages/commencement.scm (glibc-final): Inherit from GLIBC
instead of GLIBC-FINAL-WITH-BOOTSTRAP-BASH.
[propagated-inputs]: New fields.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index c38f40f618..1584f000d4 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -673,7 +673,12 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
 
 (define glibc-final
   ;; The final glibc, which embeds the statically-linked Bash built above.
-  (package (inherit glibc-final-with-bootstrap-bash)
+  (package (inherit glibc)
+  (package
+    (inherit (package
+               (inherit glibc)
+               ;; Use the source patched with %BOOTSTRAP-GUILE.
+               (source (package-source glibc-final-with-bootstrap-bash))))
     (name "glibc")
     (inputs `(("static-bash" ,static-bash-for-glibc)
               ,@(alist-delete
@@ -684,6 +689,9 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
     (native-inputs `(,@(package-native-inputs glibc-final-with-bootstrap-bash)
                      ("gettext" ,gettext-boot0)))
 
+    (propagated-inputs
+     (package-propagated-inputs glibc-final-with-bootstrap-bash))
+
     ;; The final libc only refers to itself, but the 'debug' output contains
     ;; references to GCC-BOOT0 and to the Linux headers.  XXX: Would be great
     ;; if 'allowed-references' were per-output.