summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-09-30 13:23:23 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-01 00:00:03 +0200
commitc573f5a5a5395d6b5cee3d06cbbc6a19573cf542 (patch)
tree044513a635a4de2448165a4a7c6bf4e9772f62fb /gnu/packages/commencement.scm
parenta7a1cf29485be66e606551ccfbcfcec4bc550791 (diff)
downloadguix-c573f5a5a5395d6b5cee3d06cbbc6a19573cf542.tar.gz
gnu: bash: Update to 4.4.
* gnu/packages/bash.scm (%patch-series-4.3): Remove.
(%patch-series-4.4): New variable.
(bash)[source]: Update to 4.4.
[native-inputs]: Remove.
[arguments]: Remove (ice-9 regex) modules; add (srfi srfi-26).
Inline 'install-sh-symlink' phase.  Remove 'install-headers' phase.  Add
'move-development-files' phase.
[native-search-paths]: New field.
(static-bash)[outputs]: New field.
[arguments]: Delete 'move-development-files' phase.
* gnu/packages/commencement.scm (static-bash-for-glibc)
(bash-final): Remove 'native-inputs'.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1d5c7b57f0..700de685a7 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -566,12 +566,10 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
                    ("libc" ,glibc-final-with-bootstrap-bash)
                    ,@(fold alist-delete %boot1-inputs
                            '("gcc" "libc")))))
-    (package
-      (inherit (package-with-bootstrap-guile
-                (package-with-explicit-inputs bash inputs
-                                              (current-source-location)
-                                              #:guile %bootstrap-guile)))
-      (native-inputs `(("bison" ,bison-boot0))))))
+    (package-with-bootstrap-guile
+     (package-with-explicit-inputs bash inputs
+                                   (current-source-location)
+                                   #:guile %bootstrap-guile))))
 
 (define gettext-boot0
   ;; A minimal gettext used during bootstrap.
@@ -777,13 +775,11 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
 (define bash-final
   ;; Link with `-static-libgcc' to make sure we don't retain a reference
   ;; to the bootstrap GCC.
-  (package
-    (inherit (package-with-bootstrap-guile
-              (package-with-explicit-inputs (static-libgcc-package bash)
-                                            %boot3-inputs
-                                            (current-source-location)
-                                            #:guile %bootstrap-guile)))
-    (native-inputs `(("bison" ,bison-boot0)))))
+  (package-with-bootstrap-guile
+   (package-with-explicit-inputs (static-libgcc-package bash)
+                                 %boot3-inputs
+                                 (current-source-location)
+                                 #:guile %bootstrap-guile)))
 
 (define %boot4-inputs
   ;; Now use the final Bash.