summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-09 20:59:58 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-09 20:59:58 +0200
commit680bc34da4aa067f2d35d6a4015cd33e32dfed2f (patch)
tree02e39d438d1eba7c10c9e11da579198dc357e181 /gnu/packages/commencement.scm
parentd4137d84ac75edaf2739578d0868cd77dd6da43c (diff)
downloadguix-680bc34da4aa067f2d35d6a4015cd33e32dfed2f.tar.gz
gnu: Python: Update to 3.7.4.
* gnu/packages/python.scm (python-3.7): Update to 3.7.4.
[source](snippet): Move disabled tests ...
[arguments]<#:make-flags>: ... here.  Enable previously failing tests.
<#:phases>: Add 'set-TZDIR'.
[native-inputs]: Add TZDATA-FOR-TESTS.
* gnu/packages/commencement.scm (python-boot0)[arguments]: Clear <#:make-flags>.
Delete 'set-TZDIR' phase.
* gnu/packages/patches/python-3-fix-tests.patch: Disable two new tests that do
not work in the build container.  Adjust context.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d06aa0a369..ff34392865 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1887,6 +1887,9 @@ the bootstrap environment."
                      ((#:configure-flags _ ''())
                       `(list "--without-ensurepip"
                              "--without-threads"))
+                     ;; Clear #:make-flags, such that changes to the regular
+                     ;; Python package won't interfere with this one.
+                     ((#:make-flags _ ''()) ''())
                      ((#:phases phases)
                       `(modify-phases ,phases
                          (add-before 'configure 'disable-modules
@@ -1897,7 +1900,8 @@ the bootstrap environment."
                                ;; Prevent the 'ossaudiodev' extension from being
                                ;; built, since it requires Linux headers.
                                (("'linux', ") ""))
-                             #t))))
+                             #t))
+                         (delete 'set-TZDIR)))
                      ((#:tests? _ #f) #f))))))
     (package-with-bootstrap-guile
      (package-with-explicit-inputs python %boot0-inputs