summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2019-11-22 16:03:50 +0100
committerJan Nieuwenhuizen <janneke@gnu.org>2020-02-17 23:16:42 +0100
commit562c6e3c52863a15bc22f57d2cea323fc39b452e (patch)
tree272516ba3bbf2bd6ab9a32ee6cc911973bdeaa06 /gnu/packages/commencement.scm
parent2c6728148143dc5ec543ef69d7e80cef7675e556 (diff)
downloadguix-562c6e3c52863a15bc22f57d2cea323fc39b452e.tar.gz
gnu: commencement: mesboot-headers: Use Gash instead of coretutils&co.
* gnu/packages/commencement.scm (mesboot-headers): Use Gash instead of
coretutils&co.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1cfbbd9eb6..2542231b82 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1385,8 +1385,8 @@ ac_cv_c_float_format='IEEE (little-endian)'
     (supported-systems '("i686-linux" "x86_64-linux"))
     (inputs '())
     (propagated-inputs '())
-    (native-inputs `(("coreutils" ,%bootstrap-coreutils&co)
-                     ("headers" ,%bootstrap-linux-libre-headers)))
+    (native-inputs `(("kernel-headers" ,%bootstrap-linux-libre-headers)
+                     ,@(%boot-tcc-inputs)))
     (arguments
      `(#:implicit-inputs? #f
        #:guile ,%bootstrap-guile
@@ -1400,7 +1400,7 @@ ac_cv_c_float_format='IEEE (little-endian)'
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (include (string-append out "/include"))
-                    (headers (assoc-ref %build-inputs "headers" )))
+                    (headers (assoc-ref %build-inputs "kernel-headers")))
                (mkdir-p include)
                (copy-recursively "include" out)
                (copy-recursively headers out)