summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-09-16 06:57:51 +0200
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-09-16 12:43:36 +0200
commitb85863f7ce99d05205e57358b36ff50656cca08b (patch)
treeae9e173eb281bd298ceaa74d6125b4de1be18be5 /gnu/packages/commencement.scm
parent9e7b2658d97493a5be01fb3d8c32762354c411dc (diff)
downloadguix-b85863f7ce99d05205e57358b36ff50656cca08b.tar.gz
gnu: commencement: bash-mesboot0: Break store file-name in comment.
Fixes <https://bugs.gnu.org/43005>.
Reported by Vagrant Cascadian <vagrant@debian.org>.

* gnu/packages/commencement.scm (bash-mesboot0)[arguments]: Break store file
name in comment and add unquoted string-append to silence the
’assert-no-store-file-names’ check.  The store file name check is really meant
for code; this file name was unfortunately used is a comment.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 565799c611..8a0864f26a 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -788,14 +788,17 @@ $MES -e '(mescc)' module/mescc.scm -- \"$@\"
              (substitute* "config.h"
                (("#define GETCWD_BROKEN 1") "#undef GETCWD_BROKEN"))
              (let ((config.h (open-file "config.h" "a")))
-               (display (string-append "
+               (display (string-append
+                         ;; XXX TODO: remove nested ,(string-append ...) and
+                         ;; store file name on next rebuild cycle
+                         ,(string-append "
 // tcc: error: undefined symbol 'enable_hostname_completion'
 #define enable_hostname_completion(on_or_off) 0
 
-// /gnu/store/cq0cmv35s9dhilx14zaghlc08gpc0hwr-tcc-boot0-0.9.26-6.c004e9a/lib/libc.a: error: 'sigprocmask' defined twice
+// /gnu/store/" "cq0cmv35s9dhilx14zaghlc08gpc0hwr-tcc-boot0-0.9.26-6.c004e9a/lib/libc.a: error: 'sigprocmask' defined twice
 #define HAVE_POSIX_SIGNALS 1
 #define endpwent(x) 0
-")
+"))
                         config.h)
                (close config.h))
              #t))