summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-15 14:00:00 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-15 14:06:13 +0100
commit3a0c7e7d1e9b4e0053f3dfa266c69bcc5e7ac61e (patch)
tree0b1f92eed7c8cca1204379c62882529122a47dc2 /gnu/packages/commencement.scm
parentdcaa934c3db2c8a2ad7819566585ef4a8308ef23 (diff)
downloadguix-3a0c7e7d1e9b4e0053f3dfa266c69bcc5e7ac61e.tar.gz
gnu: findutils: Update to 4.8.0.
* gnu/packages/base.scm (findutils): Update to 4.8.0.
[source](patches): Remove "findutils-test-rwlock-threads.patch".
* gnu/packages/patches/findutils-test-rwlock-threads.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/commencement.scm (findutils-boot0)[arguments]: Add
'skip-fnmatch-test' phase.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 632ee46cea..0713bcb843 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2014, 2015, 2017 Mark H Weaver <mhw@netris.org>
@@ -2549,7 +2549,17 @@ exec " gcc "/bin/" program
                  ((or "arm-linux" "aarch64-linux")
                   ''("--disable-dependency-tracking"))
                  (_ ''()))
-              ,flags)))))))
+              ,flags))
+           ((#:phases phases '%standard-phases)
+            `(modify-phases ,phases
+               (add-before 'check 'skip-fnmatch-test
+                 (lambda _
+                   ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
+                   ;; to incorrect handling of the [:alpha:] regexp character
+                   ;; class.  Ignore it.
+                   (substitute* "gnulib-tests/Makefile"
+                     (("^XFAIL_TESTS =")
+                      "XFAIL_TESTS = test-fnmatch ")))))))))))
 
 (define file
   (package