summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-12-12 22:14:57 +0100
committerLudovic Courtès <ludo@gnu.org>2015-12-13 11:28:54 +0100
commit4de35074833742e45237464bb1727ce1a55f3336 (patch)
tree99681e951acc7044923e51aea8093781f83620bd /gnu/packages/commencement.scm
parent4165fda29dcab7ae0a4cdb11d88dfe80a21c9c1d (diff)
downloadguix-4de35074833742e45237464bb1727ce1a55f3336.tar.gz
gnu: perl: Update to 5.22.0.
* gnu/packages/perl.scm (perl)[source]: Update to 5.22.0.  Remove
"perl-module-pluggable-search.patch" since Module::Pluggable appears to
be gone.
[arguments] <configure-phase>: Adjust Cwd.pm file name.  Replace
-std=c89 with -std=gnu89.
* gnu/packages/commencement.scm (perl-boot0): Add 'disable-pthreads'
phase.
* gnu/packages/patches/perl-no-sys-dirs.patch: Update.
* gnu/packages/patches/perl-module-pluggable-search.patch: Remove.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm23
1 files changed, 18 insertions, 5 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 1b0497227f..3ddaa98c2f 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -260,11 +260,24 @@
                                   (package-native-inputs gcc))))))
 
 (define perl-boot0
-  (package-with-bootstrap-guile
-   (package-with-explicit-inputs perl
-                                 %boot0-inputs
-                                 (current-source-location)
-                                 #:guile %bootstrap-guile)))
+  (let ((perl (package
+                (inherit perl)
+                (arguments
+                 (substitute-keyword-arguments (package-arguments perl)
+                   ((#:phases phases)
+                    `(modify-phases ,phases
+                       ;; Pthread support is missing in the bootstrap compiler
+                       ;; (broken spec file), so disable it.
+                       (add-before 'configure 'disable-pthreads
+                         (lambda _
+                           (substitute* "Configure"
+                             (("^libswanted=(.*)pthread" _ before)
+                              (string-append "libswanted=" before))))))))))))
+   (package-with-bootstrap-guile
+    (package-with-explicit-inputs perl
+                                  %boot0-inputs
+                                  (current-source-location)
+                                  #:guile %bootstrap-guile))))
 
 (define (linux-libre-headers-boot0)
   "Return Linux-Libre header files for the bootstrap environment."