summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-04-01 18:48:23 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-01 18:48:23 +0200
commit78ca500a7559e65a2776cff49a3d0f695d3cdf92 (patch)
tree7348be1193a5f1e0ddc4fd30b8ae800d277b1fa0 /gnu/packages/commencement.scm
parent301a4249064227bc4883e4e5b638e85a65925ba0 (diff)
downloadguix-78ca500a7559e65a2776cff49a3d0f695d3cdf92.tar.gz
gnu: commencement: Avoid extra Perl build in the DAG.
* gnu/packages/commencement.scm (grep-final): Move reference to
PERL-BOOT0 outside of 'package-with-explicit-inputs'.  Previously we
would actually depend on a variant of 'perl-boot0' built with
%BOOT5-INPUTS, which defeated the intent to not add an extra Perl build
in the DAG.
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 88297d33e8..057ee169dd 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -913,14 +913,13 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
 (define grep-final
   ;; The final grep.  Gzip holds a reference to it (via zgrep), so it must be
   ;; built before gzip.
-  (package-with-bootstrap-guile
-   (package-with-explicit-inputs (package
-                                   (inherit grep)
-                                   (inputs '())   ;no PCRE support
-                                   (native-inputs `(("perl" ,perl-boot0))))
-                                 %boot5-inputs
-                                 (current-source-location)
-                                 #:guile guile-final)))
+  (let ((grep (package-with-bootstrap-guile
+               (package-with-explicit-inputs grep %boot5-inputs
+                                             (current-source-location)
+                                             #:guile guile-final))))
+    (package/inherit grep
+                     (inputs (alist-delete "pcre" (package-inputs grep)))
+                     (native-inputs `(("perl" ,perl-boot0))))))
 
 (define %boot6-inputs
   ;; Now use the final Coreutils.