summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-07 10:52:04 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-07 10:52:04 +0200
commit9dee9e8ffe4650949bd3ad2edf559cf4a33e9e6e (patch)
treef6eef85e0c74b0c3e169a33271a8337f46866224 /gnu/packages/commencement.scm
parentaa81eb73ce6ee59c078331c709d553130e0443d3 (diff)
downloadguix-9dee9e8ffe4650949bd3ad2edf559cf4a33e9e6e.tar.gz
Revert "gnu: Default to GCC 5."
This reverts commit e3d0fcbf7e55e8cbe8d0a1c5a24d73f341d7243b.
This is a temporary measure until GCC 5 builds on ARM, see:

  https://gcc.gnu.org/bugzilla/show_bug.cgi?id=71399
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm33
1 files changed, 7 insertions, 26 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 5f3faad105..8c82644cc6 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -170,26 +170,6 @@
                     ,cf)))))
      (inputs %boot0-inputs))))
 
-(define libstdc++-boot0
-  ;; GCC's libcc1 is always built as a shared library (the top-level
-  ;; 'Makefile.def' forcefully adds --enable-shared) and thus needs to refer
-  ;; to libstdc++.so.  We cannot build libstdc++-5.3 because it relies on
-  ;; C++14 features missing in our bootstrap compiler.
-  (let ((lib (package-with-bootstrap-guile (make-libstdc++ gcc-4.9))))
-    (package
-      (inherit lib)
-      (name "libstdc++-boot0")
-      (arguments
-       `(#:guile ,%bootstrap-guile
-         #:implicit-inputs? #f
-
-         ;; XXX: libstdc++.so NEEDs ld.so for some reason.
-         #:validate-runpath? #f
-
-         ,@(package-arguments lib)))
-      (inputs %boot0-inputs)
-      (native-inputs '()))))
-
 (define gcc-boot0
   (package-with-bootstrap-guile
    (package (inherit gcc)
@@ -275,13 +255,14 @@
                ("mpc-source" ,(package-source mpc))
                ("binutils-cross" ,binutils-boot0)
 
-               ;; The libstdc++ that libcc1 links against.
-               ("libstdc++" ,libstdc++-boot0)
-
                ;; Call it differently so that the builder can check whether
                ;; the "libc" input is #f.
                ("libc-native" ,@(assoc-ref %boot0-inputs "libc"))
-               ,@(alist-delete "libc" %boot0-inputs))))))
+               ,@(alist-delete "libc" %boot0-inputs)))
+
+     ;; No need for Texinfo at this stage.
+     (native-inputs (alist-delete "texinfo"
+                                  (package-native-inputs gcc))))))
 
 (define perl-boot0
   (let ((perl (package
@@ -901,10 +882,10 @@ and binaries, plus debugging symbols in the 'debug' output), and Binutils.")
   (gcc-toolchain gcc-4.8))
 
 (define-public gcc-toolchain-4.9
-  (gcc-toolchain gcc-4.9))
+  (gcc-toolchain gcc-final))
 
 (define-public gcc-toolchain-5
-  (gcc-toolchain gcc-final))
+  (gcc-toolchain gcc-5))
 
 (define-public gcc-toolchain-6
   (gcc-toolchain gcc-6))