summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-01-11 13:50:30 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:23 +0200
commit77ee97628a2d126a31f60d4ca8fafa70a66be804 (patch)
tree9565b13511fe4bd981d5990903612e8e0e02fe34 /gnu/packages/commencement.scm
parentf9f2198d82f6aa7147700bed3f9d42a93201d620 (diff)
downloadguix-77ee97628a2d126a31f60d4ca8fafa70a66be804.tar.gz
gnu: binutils: Use gexps.
This is the result of applying ‘guix style -S arguments’ and making
small adjustments.

* gnu/packages/base.scm (binutils)[arguments]: Use gexps.
(binutils-2.33, binutils-gold): Likewise.
* gnu/packages/commencement.scm (binutils-mesboot0, binutils-mesboot1)
(binutils-boot0, binutils-final): Likewise.
* gnu/packages/cross-base.scm (cross-binutils*): Adjust accordingly.
* gnu/packages/embedded.scm (make-propeller-binutils): Use gexps.
* gnu/packages/make-bootstrap.scm (%binutils-static): Use gexps.

Change-Id: I59cbe29760784b09e6d4e80beca9153cb9b495a7
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm152
1 files changed, 78 insertions, 74 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 5bec5bc994..44ab55e365 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -937,27 +937,28 @@ MesCC-Tools), and finally M2-Planet.")
     (native-inputs (%boot-tcc-inputs))
     (supported-systems '("i686-linux" "x86_64-linux"))
     (arguments
-     `(#:implicit-inputs? #f
-       #:guile ,%bootstrap-guile
-       #:tests? #f                      ; runtest: command not found
-       #:parallel-build? #f
-       #:strip-binaries? #f             ; no strip yet
-       #:configure-flags
-       (let ((cppflags (string-append " -D __GLIBC_MINOR__=6"
-                                      " -D MES_BOOTSTRAP=1"))
-             (bash (assoc-ref %build-inputs "bash")))
-         `(,(string-append "CONFIG_SHELL=" bash "/bin/sh")
-           ,(string-append "CPPFLAGS=" cppflags)
-           "AR=tcc -ar"
-           "CXX=false"
-           "RANLIB=true"
-           ,(string-append "CC=tcc" cppflags)
-           "--disable-nls"
-           "--disable-shared"
-           "--disable-werror"
-           "--build=i686-unknown-linux-gnu"
-           "--host=i686-unknown-linux-gnu"
-           "--with-sysroot=/"))))))
+     (list #:implicit-inputs? #f
+           #:guile %bootstrap-guile
+           #:tests? #f ; runtest: command not found
+           #:parallel-build? #f
+           #:strip-binaries? #f ; no strip yet
+           #:configure-flags
+           #~(let ((cppflags (string-append
+                              " -D __GLIBC_MINOR__=6"
+                              " -D MES_BOOTSTRAP=1"))
+                   (bash (assoc-ref %build-inputs "bash")))
+               `(,(string-append "CONFIG_SHELL=" bash "/bin/sh")
+                 ,(string-append "CPPFLAGS=" cppflags)
+                 "AR=tcc -ar"
+                 "CXX=false"
+                 "RANLIB=true"
+                 ,(string-append "CC=tcc" cppflags)
+                 "--disable-nls"
+                 "--disable-shared"
+                 "--disable-werror"
+                 "--build=i686-unknown-linux-gnu"
+                 "--host=i686-unknown-linux-gnu"
+                 "--with-sysroot=/"))))))
 
 (define gcc-core-mesboot0
   ;; Gcc-2.95.3 is the most recent GCC that is supported by what the Mes C
@@ -1266,14 +1267,13 @@ ac_cv_c_float_format='IEEE (little-endian)'
     (arguments
      (substitute-keyword-arguments (package-arguments binutils-mesboot0)
        ((#:configure-flags configure-flags)
-        '(let ((out (assoc-ref %outputs "out")))
-           `("--disable-nls"
-             "--disable-shared"
-             "--disable-werror"
-             "--build=i686-unknown-linux-gnu"
-             "--host=i686-unknown-linux-gnu"
-             "--with-sysroot=/"
-             ,(string-append "--prefix=" out))))))))
+        #~(let ((out (assoc-ref %outputs "out")))
+            `("--disable-nls" "--disable-shared"
+              "--disable-werror"
+              "--build=i686-unknown-linux-gnu"
+              "--host=i686-unknown-linux-gnu"
+              "--with-sysroot=/"
+              ,(string-append "--prefix=" out))))))))
 
 (define gnu-make-mesboot
   (package
@@ -2249,33 +2249,39 @@ exec " gcc "/bin/" program
     (source (bootstrap-origin (package-source binutils)))
     (name "binutils-cross-boot0")
     (arguments
-     `(#:guile ,%bootstrap-guile
-       #:implicit-inputs? #f
-
-       #:modules ((guix build gnu-build-system)
-                  (guix build utils)
-                  (ice-9 ftw))                    ; for 'scandir'
-       #:phases (modify-phases %standard-phases
-                  (add-after 'install 'add-symlinks
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      ;; The cross-gcc invokes 'as', 'ld', etc, without the
-                      ;; triplet prefix, so add symlinks.
-                      (let ((out (assoc-ref outputs "out"))
-                            (triplet-prefix (string-append ,(boot-triplet) "-")))
-                        (define (has-triplet-prefix? name)
-                          (string-prefix? triplet-prefix name))
-                        (define (remove-triplet-prefix name)
-                          (substring name (string-length triplet-prefix)))
-                        (with-directory-excursion (string-append out "/bin")
-                          (for-each (lambda (name)
-                                      (symlink name (remove-triplet-prefix name)))
-                                    (scandir "." has-triplet-prefix?)))))))
-
-       ,@(substitute-keyword-arguments (package-arguments binutils)
-           ((#:configure-flags cf)
-            `(append (list ,(string-append "--target=" (boot-triplet))
-                           "--disable-gprofng")   ;requires Bison
-                     ,cf)))))
+     (append (list #:guile %bootstrap-guile
+                   #:implicit-inputs? #f
+
+                   #:modules '((guix build gnu-build-system)
+                               (guix build utils)
+                               (ice-9 ftw)) ; for 'scandir'
+                   #:phases
+                   #~(modify-phases %standard-phases
+                       (add-after 'install 'add-symlinks
+                         (lambda* (#:key outputs #:allow-other-keys)
+                           ;; The cross-gcc invokes 'as', 'ld', etc, without the
+                           ;; triplet prefix, so add symlinks.
+                           (let ((out (assoc-ref outputs "out"))
+                                 (triplet-prefix (string-append #$(boot-triplet)
+                                                                "-")))
+                             (define (has-triplet-prefix? name)
+                               (string-prefix? triplet-prefix name))
+                             (define (remove-triplet-prefix name)
+                               (substring name
+                                          (string-length triplet-prefix)))
+
+                             (with-directory-excursion (string-append out "/bin")
+                               (for-each (lambda (name)
+                                           (symlink name
+                                                    (remove-triplet-prefix name)))
+                                         (scandir "."
+                                                  has-triplet-prefix?))))))))
+             (substitute-keyword-arguments (package-arguments binutils)
+               ((#:configure-flags cf)
+                #~(append (list #$(string-append "--target="
+                                                 (boot-triplet))
+                                "--disable-gprofng") ;requires Bison
+                          #$cf)))))
     (native-inputs '())                           ;no Bison
     (inputs (%boot0-inputs))))
 
@@ -3182,24 +3188,22 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
     (inherit binutils)
     (source (bootstrap-origin (package-source binutils)))
     (arguments
-     `(#:guile ,%bootstrap-guile
-       #:implicit-inputs? #f
-       #:allowed-references
-       ("out"
-        ,glibc-final
-        ,(this-package-native-input "libstdc++")
-        ,@(if (target-powerpc? (%current-system))
-              (list static-bash-for-glibc)
-              '()))
-
-       ,@(substitute-keyword-arguments (package-arguments binutils)
-           ((#:configure-flags flags #~'())
-            ;; For gprofng, tell the build system where to look for libstdc++.
-            #~(append #$flags
-                      (list (string-append
-                             "LDFLAGS=-L"
-                             #$(this-package-native-input "libstdc++")
-                             "/lib")))))))
+     (append (list #:guile %bootstrap-guile
+                   #:implicit-inputs? #f
+                   #:allowed-references `("out" ,glibc-final
+                                          ,(this-package-native-input
+                                            "libstdc++")
+                                          ,@(if (target-powerpc? (%current-system))
+                                                (list static-bash-for-glibc)
+                                                '())))
+             (substitute-keyword-arguments (package-arguments binutils)
+               ((#:configure-flags flags #~'())
+                ;; For gprofng, tell the build system where to look for libstdc++.
+                #~(append #$flags
+                          (list (string-append "LDFLAGS=-L"
+                                               #$(this-package-native-input
+                                                  "libstdc++")
+                                               "/lib")))))))
     (native-inputs (list bison-boot0
                          libstdc++))              ;for gprofng
     (inputs