summary refs log tree commit diff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-07-02 20:09:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-07-02 20:19:07 +0200
commita62764bdbbc3a2bdb50047f861261bcbfd0abd77 (patch)
tree567eb411a748980fdbc41c61d546d8584aa06765 /gnu/packages/compression.scm
parent8ef7ecf4696846e747570a0b66226bf3accf9d76 (diff)
downloadguix-a62764bdbbc3a2bdb50047f861261bcbfd0abd77.tar.gz
gnu: zstd: Update to 1.3.5.
* gnu/packages/compression.scm (zstd): Update to 1.3.5.
[source]: Add two patches to make the test suite pass.
* gnu/packages/patches/zstd-fix-stdin-list-without-tty.patch,
gnu/packages/patches/zstd-fix-stdin-list-test.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add both.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index de3acaedc0..2ca431b2c1 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1649,7 +1649,7 @@ or junctions, and always follows hard links.")
 (define-public zstd
   (package
     (name "zstd")
-    (version "1.3.4")
+    (version "1.3.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/facebook/zstd/archive/v"
@@ -1657,7 +1657,11 @@ or junctions, and always follows hard links.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1a85sqk4z5b2jfp7fqkr38ibql8mdzca32lf4i3bssyjimp1pr4j"))))
+                "1sifbq18p0hc978g0pq8fymrlpzz1fcxqkbxfqk44z6v9jg5bqfn"))
+              ;; Fix a regression that causes the tests to fail.  Both patches
+              ;; have been merged upstream and will be part of the next release.
+              (patches (search-patches "zstd-fix-stdin-list-without-tty.patch"
+                                       "zstd-fix-stdin-list-test.patch"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases