summary refs log tree commit diff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-05 13:31:53 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-06 00:16:07 +0100
commit2e8a9db6efd67e5524eecae8c8d1482a9bce8004 (patch)
tree9235b4ce101f6ed7f7d8ba96fc1fdf6895a4413d /gnu/packages/compression.scm
parent0569a832683e686b1ec949bcc3e3e4069929cb95 (diff)
downloadguix-2e8a9db6efd67e5524eecae8c8d1482a9bce8004.tar.gz
gnu: lz4: Add a :static output.
* gnu/packages/compression.scm (lz4)[outputs]: Add "static" to this new
field.
[arguments]: Replace the ‘delete-static-library’ phase with
‘move-static-library’.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm33
1 files changed, 19 insertions, 14 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 43831e0ff2..818624f92e 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -798,6 +798,7 @@ decompression of some loosely related file formats used by Microsoft.")
          "0lpaypmk70ag2ks3kf2dl4ac3ba40n5kc1ainkp9wfjawz76mh61"))
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
+    (outputs (list "out" "static"))
     (native-inputs
      `(;; For tests.
        ("python" ,python)
@@ -806,20 +807,24 @@ decompression of some loosely related file formats used by Microsoft.")
      `(#:test-target "test"
        #:make-flags (list (string-append "CC=" ,(cc-for-target))
                           (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:phases (modify-phases %standard-phases
-                  (delete 'configure)            ;no configure script
-                  (add-before 'check 'disable-broken-test
-                    (lambda _
-                      ;; XXX: test_install.sh fails when prefix is a subdirectory.
-                      (substitute* "tests/Makefile"
-                        (("^test: (.*) test-install" _ targets)
-                         (string-append "test: " targets)))
-                      #t))
-                  (add-after 'install 'delete-static-library
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let ((out (assoc-ref outputs "out")))
-                        (delete-file (string-append out "/lib/liblz4.a"))
-                        #t))))))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)            ; no configure script
+         (add-before 'check 'disable-broken-test
+           (lambda _
+             (substitute* "tests/Makefile"
+               ;; This fails when $prefix is not a single top-level directory.
+               (("^test: (.*) test-install" _ targets)
+                (string-append "test: " targets)))
+             #t))
+         (add-after 'install 'move-static-library
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (static (assoc-ref outputs "static")))
+               (mkdir-p (string-append static "/lib"))
+               (rename-file (string-append out "/lib/liblz4.a")
+                            (string-append static "/lib/liblz4.a"))
+               #t))))))
     (home-page "https://www.lz4.org")
     (synopsis "Compression algorithm focused on speed")
     (description "LZ4 is a lossless compression algorithm, providing