summary refs log tree commit diff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-04-05 15:24:37 -0400
committerLeo Famulari <leo@famulari.name>2023-04-12 16:43:30 -0400
commit60c97c60a53686ec321eb541b85e01b6decc2014 (patch)
tree2fc1a09d99fa6f821fa3626c9571a27fd90618a9 /gnu/packages/compression.scm
parentdd3e5e71104a2bcbad80e52e062a144ea96b8c6a (diff)
downloadguix-60c97c60a53686ec321eb541b85e01b6decc2014.tar.gz
gnu: Zstandard: Update to 1.5.5.
This fixes a corruption bug:

https://github.com/facebook/zstd/releases/tag/v1.5.5

* gnu/packages/compression.scm (zstd)[replacement, properties]: New fields.
(zstd-1.5.5): New variable.
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index e58fd65e49..e9d7338bb4 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1635,6 +1635,13 @@ or junctions, and always follows hard links.")
 (define-public zstd
   (package
     (name "zstd")
+    ;; Replace to avoid the data corruption bug fixed in Zstd 1.5.5.
+    ;; https://github.com/facebook/zstd/releases/tag/v1.5.5
+    (replacement zstd-1.5.5)
+    ;; Hide this buggy package in the Guix UI. If you add another
+    ;; property to this package, adjust the properties in the package
+    ;; replacement accordingly.
+    (properties `((hidden? . #true)))
     (version "1.5.0")
     (source
      (origin
@@ -1721,6 +1728,20 @@ speed.")
                    license:public-domain ; zlibWrapper/examples/fitblk*
                    license:zlib))))      ; zlibWrapper/{gz*.c,gzguts.h}
 
+(define-public zstd-1.5.5
+  (package
+    (inherit zstd)
+    ;; Don't hide this package from the UI.
+    (properties '())
+    (version "1.5.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/facebook/zstd/releases/download/"
+                           "v" version "/zstd-" version ".tar.gz"))
+       (sha256
+        (base32 "1r1ydmj7ib3g5372yj3k40vl3b9ax0154qg2lqcy7ylwhb69chww"))))))
+
 (define-public pzstd
   (package/inherit zstd
     (name "pzstd")