summary refs log tree commit diff
path: root/gnu/packages/compton.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 11:33:18 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:39:40 +0200
commit4cf1acc7f3033b50b0bf19e02c9f522d522d338c (patch)
tree9fd64956ee60304c15387eb394cd649e49f01467 /gnu/packages/compton.scm
parentedb8c09addd186d9538d43b12af74d6c7aeea082 (diff)
parent595b53b74e3ef57a1c0c96108ba86d38a170a241 (diff)
downloadguix-4cf1acc7f3033b50b0bf19e02c9f522d522d338c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
 Conflicts:
	doc/guix.texi
	gnu/local.mk
	gnu/packages/admin.scm
	gnu/packages/base.scm
	gnu/packages/chromium.scm
	gnu/packages/compression.scm
	gnu/packages/databases.scm
	gnu/packages/diffoscope.scm
	gnu/packages/freedesktop.scm
	gnu/packages/gnome.scm
	gnu/packages/gnupg.scm
	gnu/packages/guile.scm
	gnu/packages/inkscape.scm
	gnu/packages/llvm.scm
	gnu/packages/openldap.scm
	gnu/packages/pciutils.scm
	gnu/packages/ruby.scm
	gnu/packages/samba.scm
	gnu/packages/sqlite.scm
	gnu/packages/statistics.scm
	gnu/packages/syndication.scm
	gnu/packages/tex.scm
	gnu/packages/tls.scm
	gnu/packages/version-control.scm
	gnu/packages/xml.scm
	guix/build-system/copy.scm
	guix/scripts/home.scm
Diffstat (limited to 'gnu/packages/compton.scm')
-rw-r--r--gnu/packages/compton.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
index 16feae4f2f..42af93aa31 100644
--- a/gnu/packages/compton.scm
+++ b/gnu/packages/compton.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2019 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +24,7 @@
 (define-module (gnu packages compton)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
@@ -111,7 +113,7 @@ performance).
 (define-public picom
   (package
     (name "picom")
-    (version "9.1")
+    (version "10.2")
     (source
      (origin
        (method git-fetch)
@@ -120,7 +122,7 @@ performance).
              (commit (string-append "v" version))))
        (sha256
         (base32
-         "0q7j6kh9k7i201cwhnfc3bmp0hqrx7ngk3v4qsp8k0qfy1n3ma8n"))
+         "1vd4nhvfykwdhpyhb0jmcj333zxhm6dyikafd76fa4z4fhjrrs0b"))
        (file-name (string-append "picom-" version))))
     (build-system meson-build-system)
     (inputs
@@ -140,8 +142,20 @@ performance).
     (native-inputs
      (list asciidoc pkg-config xorgproto))
     (arguments
-     `(#:build-type "release"
-       #:configure-flags '("-Dwith_docs=true")))
+     (list #:build-type "release"
+           #:configure-flags #~'("-Dwith_docs=true")
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; This file would be patched by 'patch-dot-desktop-files but
+               ;; only in share/applications and not etc/xdg/autostart, so
+               ;; manually patch it before it is installed in either location.
+               ;; The 'patch-dot-desktop-files phase is still needed for other
+               ;; .desktop files.
+               (add-after 'unpack 'patch-autostart-files
+                 (lambda _
+                   (substitute* "picom.desktop"
+                     (("Exec=")
+                      (string-append "Exec=" #$output "/bin/"))))))))
     (home-page "https://github.com/yshui/picom")
     (synopsis "Compositor for X11, forked from Compton")
     (description