summary refs log tree commit diff
path: root/gnu/packages/compton.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-01-13 13:44:34 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-01-13 13:44:34 -0500
commit0f85081ed1d99be57d3544e0307e7fa9ca043be9 (patch)
tree4fcf16444acee4eaff07767bb016cdb218ad45ea /gnu/packages/compton.scm
parentfc8c3fabcd0176918c8955926ff7eb6362151929 (diff)
downloadguix-0f85081ed1d99be57d3544e0307e7fa9ca043be9.tar.gz
gnu: picom: Update to 10.2.
* gnu/packages/compton.scm (picom): Update to 10.2.
[arguments]: Use a plain list and adjust accordingly.
[phases]{patch-autostart-files}: New phase.
Diffstat (limited to 'gnu/packages/compton.scm')
-rw-r--r--gnu/packages/compton.scm22
1 files changed, 18 insertions, 4 deletions
diff --git a/gnu/packages/compton.scm b/gnu/packages/compton.scm
index 16feae4f2f..42af93aa31 100644
--- a/gnu/packages/compton.scm
+++ b/gnu/packages/compton.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2019 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +24,7 @@
 (define-module (gnu packages compton)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system meson)
@@ -111,7 +113,7 @@ performance).
 (define-public picom
   (package
     (name "picom")
-    (version "9.1")
+    (version "10.2")
     (source
      (origin
        (method git-fetch)
@@ -120,7 +122,7 @@ performance).
              (commit (string-append "v" version))))
        (sha256
         (base32
-         "0q7j6kh9k7i201cwhnfc3bmp0hqrx7ngk3v4qsp8k0qfy1n3ma8n"))
+         "1vd4nhvfykwdhpyhb0jmcj333zxhm6dyikafd76fa4z4fhjrrs0b"))
        (file-name (string-append "picom-" version))))
     (build-system meson-build-system)
     (inputs
@@ -140,8 +142,20 @@ performance).
     (native-inputs
      (list asciidoc pkg-config xorgproto))
     (arguments
-     `(#:build-type "release"
-       #:configure-flags '("-Dwith_docs=true")))
+     (list #:build-type "release"
+           #:configure-flags #~'("-Dwith_docs=true")
+           #:phases
+           #~(modify-phases %standard-phases
+               ;; This file would be patched by 'patch-dot-desktop-files but
+               ;; only in share/applications and not etc/xdg/autostart, so
+               ;; manually patch it before it is installed in either location.
+               ;; The 'patch-dot-desktop-files phase is still needed for other
+               ;; .desktop files.
+               (add-after 'unpack 'patch-autostart-files
+                 (lambda _
+                   (substitute* "picom.desktop"
+                     (("Exec=")
+                      (string-append "Exec=" #$output "/bin/"))))))))
     (home-page "https://github.com/yshui/picom")
     (synopsis "Compositor for X11, forked from Compton")
     (description