summary refs log tree commit diff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-16 19:51:51 +0100
committerJulien Lepiller <julien@lepiller.eu>2021-11-18 04:08:08 +0100
commit7b93c6d77786c27171900045f62be0fce69432f7 (patch)
treec3b0197ed0b64d84b930e5fcb0de160b6826a246 /gnu/packages/coq.scm
parent2d60af4d6d486591c5a6981659d1771b7c69781a (diff)
downloadguix-7b93c6d77786c27171900045f62be0fce69432f7.tar.gz
gnu: coq-mathcomp: Adjust '#:make-flags'.
* gnu/packages/coq.scm (coq-mathcomp)[arguments]<#:make-flags>: Set install
destination.
<#:phases>: Remove replace 'install.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 322bdb126e..602a2d305d 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -326,17 +326,14 @@ assistant.")
        ("coq" ,coq)))
     (arguments
      `(#:tests? #f ; No tests.
+       #:make-flags (list (string-append "COQLIBINSTALL="
+                                         (assoc-ref %outputs "out")
+                                         "/lib/coq/user-contrib"))
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
          (add-before 'build 'chdir
-           (lambda _ (chdir "mathcomp") #t))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "make" "-f" "Makefile.coq"
-                     (string-append "COQLIB=" (assoc-ref outputs "out")
-                                    "/lib/coq/")
-                     "install"))))))
+           (lambda _ (chdir "mathcomp") #t)))))
     (home-page "https://math-comp.github.io/")
     (synopsis "Mathematical Components for Coq")
     (description "Mathematical Components for Coq has its origins in the formal