summary refs log tree commit diff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-01-06 01:39:52 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-06 21:06:44 -0600
commitd481db8baf809e0537a4d4aa4fe9b8e22b1d86e6 (patch)
tree0786e24bcc902e61e6e66fd19c0070b365d36f6a /gnu/packages/coq.scm
parenta61fe4c04e075a170af72a9b8b04b136af249b69 (diff)
downloadguix-d481db8baf809e0537a4d4aa4fe9b8e22b1d86e6.tar.gz
gnu: coq-coquelicot: Update to 3.0.3.
* gnu/packages/coq.scm (coq-coquelicot): Update to 3.0.3.
[source]: Use GIT-FETCH and GIT-FILE-NAME.
[native-inputs]: Add autoconf and automake.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index acae58a10d..0e4a1f260e 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -367,17 +367,22 @@ part of the distribution.")
 (define-public coq-coquelicot
   (package
     (name "coq-coquelicot")
-    (version "3.0.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://gforge.inria.fr/frs/download.php/"
-                                  "file/37523/coquelicot-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1biia7nfqf7vaqq5gmykl4rwjyvrcwss6r2jdf0in5pvp2rnrj2w"))))
+    (version "3.0.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.inria.fr/coquelicot/coquelicot.git")
+             (commit (string-append "coquelicot-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0m5wbr2s8lnf8b7cfwv15hyzsmbcaz6hgdn7aazcrkxnwr87vgkp"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("ocaml" ,ocaml)
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("ocaml" ,ocaml)
        ("which" ,which)
        ("coq" ,coq)))
     (propagated-inputs