summary refs log tree commit diff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-25 11:39:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:19 +0100
commite09e83880f0ad1901011ae516db59495fe582caa (patch)
tree856116414bafd8418d9d4051fe3207631eb08e72 /gnu/packages/coq.scm
parent1530b17aa14df91399f2dab0f5ee7951e27c6071 (diff)
downloadguix-e09e83880f0ad1901011ae516db59495fe582caa.tar.gz
gnu: coq-coquelicot: Use INVOKE.
* gnu/packages/coq.scm (coq-coquelicot)[arguments]: Use INVOKE.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index 076aa7f7b9..f4d7cc2b79 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -347,16 +347,14 @@ part of the distribution.")
          (add-before 'configure 'fix-remake
            (lambda _
              (substitute* "remake.cpp"
-               (("/bin/sh") (which "sh")))))
+               (("/bin/sh") (which "sh")))
+             #t))
          (replace 'build
-           (lambda _
-             (zero? (system* "./remake"))))
+           (lambda _ (invoke "./remake")))
          (replace 'check
-           (lambda _
-             (zero? (system* "./remake" "check"))))
+           (lambda _ (invoke "./remake" "check")))
          (replace 'install
-           (lambda _
-             (zero? (system* "./remake" "install")))))))
+           (lambda _ (invoke "./remake" "install"))))))
     (home-page "http://coquelicot.saclay.inria.fr/index.html")
     (synopsis "Coq library for Reals")
     (description "Coquelicot is an easier way of writing formulas and theorem