summary refs log tree commit diff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-02-11 08:42:22 +0100
committerJulien Lepiller <julien@lepiller.eu>2022-02-11 10:32:56 +0100
commit5179f4525d0859794b0d75ee1792d0f731d1f9c4 (patch)
tree367de193e54a50d39f21792de4e534765411cf99 /gnu/packages/coq.scm
parent6b6474fec71c30a105e9d98f050b29a798b58a0b (diff)
downloadguix-5179f4525d0859794b0d75ee1792d0f731d1f9c4.tar.gz
gnu: coq: Update to 8.15.0.
* gnu/packages/coq.scm (coq): Update to 8.15.0.
(coq-equations): Update to 1.3-8.15.
* gnu/packages/patches/coq-fix-envvars.patch: Adapt to new version.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index bdd57cd47c..13c0a2f9db 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -52,7 +52,7 @@
 (define-public coq-core
   (package
     (name "coq-core")
-    (version "8.14.1")
+    (version "8.15.0")
     (source
      (origin
        (method git-fetch)
@@ -62,7 +62,7 @@
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0q634fmrh5ivpxy7ammdiqdh9xp72ji2726vcz1bd55ln0d08z40"))
+         "0473mmc4wv8zbbcbvqqn0z9gz9y8gf4w2q6j6h50lx0jphpg2n8z"))
        (patches (search-patches "coq-fix-envvars.patch"))))
     (native-search-paths
      (list (search-path-specification
@@ -546,11 +546,11 @@ uses Ltac to synthesize the substitution operation.")
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/mattam82/Coq-Equations")
-                    (commit (string-append "v" version "-8.14"))))
+                    (commit (string-append "v" version "-8.15"))))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "19bj9nncd1r9g4273h5qx35gs3i4bw5z9bhjni24b413hyj55hkv"))))
+                "1vfcfpsp9zyj0sw0cwibk76nj6n0r6gwh8m1aa3lbvc0b1kbm32k"))))
     (build-system gnu-build-system)
     (native-inputs
      (list ocaml coq camlp5))