summary refs log tree commit diff
path: root/gnu/packages/coq.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-23 11:06:13 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-13 05:42:57 +0100
commit8b9b2210dc1a7e1ac63bd85df9e8d0c39c59a3f0 (patch)
treefeb2d7acb9a8473e0d2c8774efb981cc6df21577 /gnu/packages/coq.scm
parent90325cf7e205b7e3fbd8df978abbde095053c1e6 (diff)
downloadguix-8b9b2210dc1a7e1ac63bd85df9e8d0c39c59a3f0.tar.gz
gnu: coq: Don't use unstable tarball.
* gnu/packages/coq.scm (coq)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
[arguments]: Add 'make-git-checkout-writable' phase.
Diffstat (limited to 'gnu/packages/coq.scm')
-rw-r--r--gnu/packages/coq.scm22
1 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index e42f8af1ab..6cedb8363f 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Dan Frumin <dfrumin@cs.ru.nl>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -42,14 +43,15 @@
   (package
     (name "coq")
     (version "8.8.2")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/coq/coq/archive/V"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0i2hs0i6rp27cy8zd0mx7jscqw5cx2y0diw0pxgij66s3yr47y7r"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/coq/coq.git")
+             (commit (string-append "V" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03v8b57mz3ivsijwxy51avzwiyhla5ijaf98a5a2q29yabdq8dkp"))))
     (native-search-paths
      (list (search-path-specification
             (variable "COQPATH")
@@ -63,6 +65,10 @@
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'make-git-checkout-writable
+           (lambda _
+             (for-each make-file-writable (find-files "."))
+             #t))
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))