summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-04-27 20:57:58 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-05-14 12:22:29 +0200
commit58e84ec9afd11b21fae1a87e149902f965326239 (patch)
tree3ce663b78516cb36ba4fc53e98b6b3b8f573779f /gnu/packages/cpp.scm
parent3c8d0f9e71bbddfb5b1f098c713ff37553f0efcc (diff)
downloadguix-58e84ec9afd11b21fae1a87e149902f965326239.tar.gz
gnu: Rename json-modern-cxx to nlohmann-json.
* gnu/packages/cpp.scm (nlohmann-json): New variable.
(json-modern-cxx): Mark as deprecated alias.
(xtl, jsonnet)[inputs]: Use nlohmann-json.
* gnu/packages/build-tools.scm (bear)[inputs]: Likewise.
* gnu/packages/cybersecurity.scm (blacksmith)[inputs]: Likewise.
* gnu/packages/databases.scm (sqlitebrowser)[inputs]: Adjust comment.
* gnu/packages/games.scm (openrct2)[inputs]: Use nlohmann-json.
* gnu/packages/graphics.scm (f3d)[native-inputs]: Likewise.
* gnu/packages/hardware.scm (openrgb)[inputs]: Likewise.
[arguments]: Adjust accordingly.
* gnu/packages/image-processing.scm (paraview)[inputs]: Adjust comment.
* gnu/packages/irods.scm (irods, irods-client-icommands)[inputs]: Use
nlohmann-json.
* gnu/packages/jupyter.scm (xeus)[inputs]: Likewise.
* gnu/packages/messaging.scm (mtxclient, nheko)[inputs]: Likewise.
* gnu/packages/text-editors.scm (jucipp)[inputs]: Likewise.
* gnu/packages/video.scm (mktoolnix)[inputs]: Likewise.
* gnu/packages/xdisorg.scm (nwg-launchers)[inputs]: Likewise.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 242ea088bb..02dbcd226a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -596,9 +596,9 @@ converting data between JSON representation and C++ structs.  DTO stands for
 data transfer object.")
     (license license:bsd-3)))
 
-(define-public json-modern-cxx
+(define-public nlohmann-json
   (package
-    (name "json-modern-cxx")
+    (name "nlohmann-json")
     (version "3.10.5")
     (home-page "https://github.com/nlohmann/json")
     (source
@@ -662,10 +662,13 @@ data transfer object.")
     (inputs
      (list doctest fifo-map))
     (synopsis "JSON parser and printer library for C++")
-    (description "JSON for Modern C++ is a C++ JSON library that provides
+    (description "@code{nlohmann::json} is a C++ JSON library that provides
 intuitive syntax and trivial integration.")
     (license license:expat)))
 
+(define-public json-modern-cxx
+  (deprecated-package "json-modern-cxx" nlohmann-json))
+
 (define-public xtl
   (package
     (name "xtl")
@@ -681,7 +684,7 @@ intuitive syntax and trivial integration.")
                 "134pgvmf9cx5dxs0m0m3qhp3m3r1gl86ic3xax21zc4sdj8sdq46"))
               (file-name (git-file-name name version))))
     (native-inputs
-     (list doctest googletest json-modern-cxx))
+     (list doctest googletest nlohmann-json))
     (arguments
      '(#:configure-flags
        '("-DBUILD_TESTS=ON")
@@ -1860,7 +1863,7 @@ of reading and writing XML.")
     (native-inputs
      (list googletest pkg-config))
     (inputs
-     (list json-modern-cxx))
+     (list nlohmann-json))
     (home-page "https://jsonnet.org/")
     (synopsis "Data templating language")
     (description "Jsonnet is a templating language extending JSON