summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-31 23:32:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-31 23:32:56 +0100
commit0747328e317de4bf936fab50e795d1e1523adfc1 (patch)
tree291d4f07a801b147d64faec31e4394c5cd46ce35 /gnu/packages/cpp.scm
parentdf09e1d6e71f68a8fb44bcc9f13e625f9f9701a5 (diff)
parentff75441fcf0ba1212b0342f933a8999bafe60f03 (diff)
downloadguix-0747328e317de4bf936fab50e795d1e1523adfc1.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index f5aa447a79..4e8f12248f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -203,15 +203,16 @@ as ordering relation.")
   (package
     (name "json-modern-cxx")
     (version "3.1.2")
+    (home-page "https://github.com/nlohmann/json")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/nlohmann/json/archive/v" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference (url home-page)
+                           (commit (string-append "v" version))))
        (sha256
         (base32
-         "0m5fhdpx2qll933db2nsi30nns3cifavzvijzz6mxhdkpmngmzz8"))
-       (file-name (string-append name "-" version ".tar.gz"))
+         "1mpr781fb2dfbyscrr7nil75lkxsazg4wkm749168lcf2ksrrbfi"))
+       (file-name (git-file-name name version))
        (modules '((guix build utils)))
        (snippet
         '(begin
@@ -227,13 +228,13 @@ as ordering relation.")
                (substitute* files
                  (("#include ?\"(fifo_map.hpp)\"" all fifo-map-hpp)
                   (string-append
-                   "#include <fifo_map/" fifo-map-hpp ">")))))))))
+                   "#include <fifo_map/" fifo-map-hpp ">")))))
+           #t))))
     (native-inputs
      `(("amalgamate" ,amalgamate)))
     (inputs
      `(("catch2" ,catch-framework2)
        ("fifo-map" ,fifo-map)))
-    (home-page "https://github.com/nlohmann/json")
     (build-system cmake-build-system)
     (synopsis "JSON parser and printer library for C++")
     (description "JSON for Modern C++ is a C++ JSON library that provides