summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-01-06 12:21:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-01-06 12:28:15 +0100
commita768b0433e0b79c5a32910ce5515086b92725e84 (patch)
tree44bd2d0cd20c245fef3daf707fc499e57e11f10b /gnu/packages/cpp.scm
parent8be0a97a8139fdd4d196092008b98668f1a8b2bb (diff)
downloadguix-a768b0433e0b79c5a32910ce5515086b92725e84.tar.gz
gnu: Add psascan.
* gnu/packages/cpp.scm (psascan): New variable.
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index cc594e56c5..f0486a511e 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -74,6 +74,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages datastructures)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gcc)
@@ -1114,6 +1115,39 @@ a zero-dependency C++ header-only parser combinator library for creating
 parsers according to a Parsing Expression Grammar (PEG).")
     (license license:expat)))
 
+(define-public psascan
+  (package
+    (name "psascan")
+    (version "0.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.cs.helsinki.fi/group"
+                                  "/pads/software/pSAscan"
+                                  "/pSAscan-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1cphk4gf202nzkxz6jdjzls4zy27055gwpm0r8cn99gr6c8548cy"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #false ;there are none
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir (lambda _ (chdir "src")))
+          (delete 'configure)
+          (replace 'install
+            (lambda _
+              (install-file "psascan"
+                            (string-append #$output "/bin")))))))
+    (inputs (list libdivsufsort))
+    (home-page "https://www.cs.helsinki.fi/group/pads/pSAscan.html")
+    (synopsis "Parallel external memory suffix array construction")
+    (description "This package contains an implementation of the parallel
+external-memory suffix array construction algorithm called pSAscan.  The
+algorithm is based on the sequential external-memory suffix array construction
+algorithm called SAscan.")
+    (license license:expat)))
+
 (define-public cxxopts
   (package
     (name "cxxopts")