summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-04-27 15:08:25 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-28 21:13:36 +0200
commit4884ee6dd4b1694a4a502dd8058d6c61fa0c0199 (patch)
treefef3a27779d69b74481b1178fc02bd628a6d44da /gnu/packages/cpp.scm
parent8a8bd15bfa640e2a377f44ab1c59c5be0c525f86 (diff)
downloadguix-4884ee6dd4b1694a4a502dd8058d6c61fa0c0199.tar.gz
gnu: libexpected: Update to 1.1.0.
* gnu/packages/patches/libexpected-use-provided-catch2.patch: Add new patch.
* gnu/packages/patches/libexpected-nofetch.patch: Remove unused patch.
* gnu/local.mk (dist_patch_DATA): Register changes.
* gnu/packages/cpp.scm (libexpected): Update to 1.1.0, and use new patch.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index bb1f216e2a..023d1c0337 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -1363,7 +1363,7 @@ services including database, analytic, and machine learning technologies.")
 (define-public libexpected
   (package
     (name "libexpected")
-    (version "1.0.0")
+    (version "1.1.0")
     (source
      (origin
        (method git-fetch)
@@ -1374,18 +1374,10 @@ services including database, analytic, and machine learning technologies.")
              ;; repository. Should not affect reproducibility.
              (recursive? #t)))
        (file-name (git-file-name name version))
-       ;; NOTE: This patch will be unnecessary on subsequent tags.
-       (patches (search-patches "libexpected-nofetch.patch"))
        (sha256
-        (base32 "1ckzfrljzzdw9wf8hvdfjz4wjx5na57iwxc48mbv9rf5067m21a5"))))
+        (base32 "17akrv80h0n4cfmxwvlvbb8ycqza7y3qqygjyphv95rrabqm9r02"))
+       (patches (search-patches "libexpected-use-provided-catch2.patch"))))
     (build-system cmake-build-system)
-    ;; TODO: Clean up install phase.
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda _
-             (invoke "./tests"))))))
     (native-inputs
      (list catch2))
     (synopsis "C++11/14/17 std::expected with functional-style extensions")