summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-01-21 19:31:16 +0000
committerLudovic Courtès <ludo@gnu.org>2018-01-23 10:28:27 +0100
commita893dc2f484f89d9f0ba21d44bdac3b792872781 (patch)
tree02b7f150e13f6a5baf3dfea9f7919dc5e36579b3 /gnu/packages/cpp.scm
parent6055e88c0d6212884d5f050eea1cefc4fcaec043 (diff)
downloadguix-a893dc2f484f89d9f0ba21d44bdac3b792872781.tar.gz
gnu: rct: Add missing headers, enable RTTI.
* gnu/packages/patches/rct-add-missing-headers.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/cpp.scm (rct): Use the patch, enable RTTI.
[source]: Use the patch to add missing headers from installation.
[arguments]: Enable RTTI in configure-flags.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 7f711d5542..95e82fcb61 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -68,7 +68,7 @@ operating system functions.")
 
 (define-public rct
   (let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
-         (revision "1")
+         (revision "2")
          (version (git-version "0.0.0" revision commit)))
     (package
       (name "rct")
@@ -82,11 +82,13 @@ operating system functions.")
                 (sha256
                  (base32
                   "1m2931jacka27ghnpgf1z1plkkr64z0pga4r4zdrfpp2d7xnrdvb"))
+                (patches (search-patches "rct-add-missing-headers.patch"))
                 (file-name (git-file-name name version))))
       (build-system cmake-build-system)
       (arguments
        '(#:configure-flags
-         '("-DWITH_TESTS=ON")))           ; To run the test suite
+         '("-DWITH_TESTS=ON"            ; To run the test suite
+           "-DRCT_RTTI_ENABLED=ON")))
       (native-inputs
        `(("cppunit" ,cppunit)
          ("pkg-config" ,pkg-config)))