summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-08-10 10:28:35 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-08-11 00:32:42 +0200
commit3775006f241e89d3c937e23e36f8c36869d9f928 (patch)
tree2a1b1cc77b9d78e2580e5aaac1a22420e67918da /gnu/packages/cran.scm
parent16e2547df5774841c59941cbabda65a6cba1244b (diff)
downloadguix-3775006f241e89d3c937e23e36f8c36869d9f928.tar.gz
gnu: Add r-partr2.
* gnu/packages/bioinformatics.scm (r-partr2): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 51e1a8e9d1..b16d4ab3a9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14652,6 +14652,35 @@ based on entropy estimates from k-nearest neighbors distances and algorithms
 for the reconstruction of gene regulatory networks.")
     (license license:agpl3+)))
 
+(define-public r-partr2
+  (package
+    (name "r-partr2")
+    (version "0.9.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "partR2" version))
+              (sha256
+               (base32
+                "06ky0hhrq0mcsn9rwrzvwn0rrjj0l8rxs0hqp10668gdq5hjk8bn"))))
+    (properties `((upstream-name . "partR2")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-dplyr
+                             r-ggplot2
+                             r-lme4
+                             r-magrittr
+                             r-pbapply
+                             r-purrr
+                             r-rlang
+                             r-tibble
+                             r-tidyr))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/mastoffel/partR2")
+    (synopsis "Partitioning R2 in generalized linear mixed models")
+    (description
+     "This package provides an R tool for estimating and partitioning R2 in
+@dfn{generalized linear mixed models} (GLMMs) based on predictor variance.")
+    (license license:gpl2+)))
+
 (define-public r-pscl
   (package
     (name "r-pscl")