summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2024-05-08 03:02:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-08 15:07:04 +0200
commit4171f8bf3fcf13dba1a22ace82633973c8f951ee (patch)
treeccc138937fd94cd1b62dc19bc17043660a91067d /gnu/packages/cran.scm
parent938f1c065ed0d80851ff9f90d3175e9426d2f5a0 (diff)
downloadguix-4171f8bf3fcf13dba1a22ace82633973c8f951ee.tar.gz
gnu: Add r-mlr3data.
* gnu/packages/cran.scm (r-mlr3data): New variable.

Change-Id: I93bee828d1ac26da1146c853b4d88fbdec42905f
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d106466451..7fc7f9bf8e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -37935,6 +37935,30 @@ customization by the user.")
      "This package extends the mlr3 package with cluster analysis.")
     (license license:lgpl3)))
 
+(define-public r-mlr3data
+  (package
+    (name "r-mlr3data")
+    (version "0.7.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mlr3data" version))
+       (sha256
+        (base32 "04hwmj8cdszwgd845va26pgzdw0k4cm025zjrmp3fr7ypp73mirg"))))
+    (properties `((upstream-name . "mlr3data")))
+    (build-system r-build-system)
+    (home-page "https://github.com/mlr-org/mlr3data")
+    (synopsis "Collection of machine learning data Sets for mlr3")
+    (description
+     "This package provides a small collection of interesting and educational
+machine learning data sets which are used as examples in the mlr3 book Applied
+machine learning using mlr3 in R @url{https://mlr3book.mlr-org.com}, the use case
+gallery  @url{https://mlr3gallery.mlr-org.com}, or in other examples.  All data
+sets are properly preprocessed and ready to be analyzed by most machine learning
+algorithms.  Data sets are automatically added to the dictionary of tasks if
+mlr3 is loaded.")
+    (license license:lgpl3)))
+
 (define-public r-mlr3measures
   (package
     (name "r-mlr3measures")