summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-17 19:18:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-17 20:02:15 +0100
commit5828dd030b4cf3920573f7982420999aa5743100 (patch)
tree5a3c3eaa09403bc138e043a1f3d24209008143a1 /gnu/packages/cran.scm
parent595036d9f9242ffe7adf6a20a2833342ba35a041 (diff)
downloadguix-5828dd030b4cf3920573f7982420999aa5743100.tar.gz
gnu: Add r-poibin.
* gnu/packages/cran.scm (r-poibin): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 795e5db4f1..24eade12ec 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18810,3 +18810,26 @@ nearest neighbors (kNN) of a data matrix.  The implementation is based on
 cover trees introduced by Alina Beygelzimer, Sham Kakade, and John
 Langford (2006) @url{doi:10.1145/1143844.1143857}.")
     (license license:agpl3+)))
+
+(define-public r-poibin
+  (package
+    (name "r-poibin")
+    (version "1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "poibin" version))
+       (sha256
+        (base32
+         "1rllgmk7yanb5amysl33kmi11lx86q5kqblyb8qqb3ckj2w4jhm2"))))
+    (properties `((upstream-name . "poibin")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/poibin/")
+    (synopsis "Poisson binomial distribution")
+    (description
+     "This package provides an implementation of both the exact and
+approximation methods for computing the @dfn{cumulative distribution
+function} (CDF) of the Poisson binomial distribution.  It also provides the
+@dfn{probability mass function} (PMF), quantile function, and random number
+generation for the Poisson binomial distribution.")
+    (license license:gpl2)))