summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-03-20 19:03:39 +0100
committerAndreas Enge <andreas@enge.fr>2023-03-20 19:03:39 +0100
commitbfe569e84b539c505e1e432d8ceea91e1481e904 (patch)
tree28c31458050f9dbc134a03c0e188d460bee50c20 /gnu/packages/cran.scm
parentccb62d8feb50e2859d7c41429a9e3d9e0fe30bfe (diff)
parent30f4b3a7e87f6d89d36dad63d8c5a8d065050563 (diff)
downloadguix-bfe569e84b539c505e1e432d8ceea91e1481e904.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ad6f92ba7b..33761933a3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2818,6 +2818,27 @@ designed to make it easy to install and load multiple tidyverse packages in a
 single step.")
     (license license:gpl3)))
 
+(define-public r-tkrplot
+  (package
+    (name "r-tkrplot")
+    (version "0.0-27")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tkrplot" version))
+       (sha256
+        (base32 "19bj4wn1fs4wrx5k4gakhpz4q59fgx0584wyaw7hnh0ljj8i34n9"))))
+    (properties `((upstream-name . "tkrplot")))
+    (build-system r-build-system)
+    (inputs (list libx11))
+    (home-page "https://cran.r-project.org/package=tkrplot")
+    (synopsis "Place R graphics in a Tk widget")
+    (description
+     "The tkrplot package lets you place R graphics in a @dfn{Tk,
+cross-platform graphical user interface toolkit} widget.")
+    ;; Any version of the GPL.
+    (license (list license:gpl2+ license:gpl3+))))
+
 (define-public r-rvest
   (package
     (name "r-rvest")