summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-15 13:36:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 13:45:29 +0100
commit78373e394dc1d0e04d76c491767ffa527920f3b3 (patch)
treea8f9daa685b92780acfea2a51b1896a54d351e46 /gnu/packages/cran.scm
parent1ed435bf394eee1a6cd9c354efb405920c212f0e (diff)
downloadguix-78373e394dc1d0e04d76c491767ffa527920f3b3.tar.gz
gnu: Add r-spatstat-sparse.
* gnu/packages/cran.scm (r-spatstat-sparse): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 30c346d0c1..6ae746a093 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -24809,6 +24809,33 @@ diagonals.  This package allows you to compute the tensor product of arrays.")
 which may also be useful for other purposes.")
     (license license:gpl2+)))
 
+(define-public r-spatstat-sparse
+  (package
+    (name "r-spatstat-sparse")
+    (version "1.2-1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "spatstat.sparse" version))
+       (sha256
+        (base32
+         "1w312q7gxzchigxxzk9akscdsz66j5085lgjryamschjgp4f8yk2"))))
+    (properties
+     `((upstream-name . "spatstat.sparse")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-abind" ,r-abind)
+       ("r-matrix" ,r-matrix)
+       ("r-spatstat-utils" ,r-spatstat-utils)
+       ("r-tensor" ,r-tensor)))
+    (home-page "http://spatstat.org/")
+    (synopsis "Sparse three-dimensional arrays and linear algebra utilities")
+    (description
+     "This package defines sparse three-dimensional arrays and supports
+standard operations on them.  The package also includes utility functions for
+matrix calculations that are common in statistics, such as quadratic forms.")
+    (license license:gpl2+)))
+
 (define-public r-spatstat-data
   (package
     (name "r-spatstat-data")