summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-24 23:31:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-24 23:44:12 +0100
commitd884e4072bc6dbf65578ce4fa5f8995b179998ae (patch)
tree106506c8115397d55e1130b72980954269da0449 /gnu/packages/cran.scm
parentdcc502865c6f1c88065747cc3daf63ceb1bdc796 (diff)
downloadguix-d884e4072bc6dbf65578ce4fa5f8995b179998ae.tar.gz
gnu: Add r-sf.
* gnu/packages/cran.scm (r-sf): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2916bfa685..4c823ab232 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -47,6 +47,7 @@
   #:use-module (gnu packages databases)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gcc)
+  #:use-module (gnu packages geo)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages gnome)
@@ -12145,3 +12146,37 @@ ways, clips tessellations to sub-windows, calculates perimeters of
 tessellations, and summarizes information about the tiles of the
 tessellation.")
     (license license:gpl2+)))
+
+(define-public r-sf
+  (package
+    (name "r-sf")
+    (version "0.7-3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "sf" version))
+       (sha256
+        (base32
+         "1b9lbid0hmmz8m5vhg8mi2mi2rclia6qwzd1jr8s81i2l0md828d"))))
+    (build-system r-build-system)
+    (inputs
+     `(("gdal" ,gdal)
+       ("geos" ,geos)
+       ("proj" ,proj.4)
+       ("zlib" ,zlib)))
+    (propagated-inputs
+     `(("r-classint" ,r-classint)
+       ("r-dbi" ,r-dbi)
+       ("r-magrittr" ,r-magrittr)
+       ("r-rcpp" ,r-rcpp)
+       ("r-units" ,r-units)))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/r-spatial/sf/")
+    (synopsis "Simple features for R")
+    (description
+     "This package provides support for simple features, a standardized way to
+encode spatial vector data.  It binds to GDAL for reading and writing data, to
+GEOS for geometrical operations, and to PROJ for projection conversions and
+datum transformations.")
+    ;; Either of these licenses
+    (license (list license:gpl2 license:expat))))