summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-09 16:55:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-09 16:57:13 +0100
commitff939ef4d53af151683fbbae389cf60d76aef6ae (patch)
tree4971d006cb3fe430954bb3d6ba6ccaec693eb146 /gnu/packages/cran.scm
parent3a4c6288c81d91ce48200a310ad0d83bddfb7a5a (diff)
downloadguix-ff939ef4d53af151683fbbae389cf60d76aef6ae.tar.gz
gnu: Add r-h5.
* gnu/packages/cran.scm (r-h5): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 33dda347b5..e22c5010d9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32,6 +32,7 @@
   #:use-module (guix download)
   #:use-module (guix utils)
   #:use-module (guix build-system r)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gnome)
@@ -3472,6 +3473,36 @@ dendrograms.")
     ;; Either version of the license.
     (license (list license:gpl2 license:gpl3))))
 
+(define-public r-h5
+  (package
+    (name "r-h5")
+    (version "0.9.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "h5" version))
+       (sha256
+        (base32
+         "14p7i1sj24ky87kd7qr3n9fc9l64s0bp0rwbyl6i2x69xn75gpsx"))))
+    (build-system r-build-system)
+    (inputs
+     `(("zlib" ,zlib)
+       ("hdf5" ,hdf5)))
+    (native-inputs
+     `(("which" ,which)))
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/mannau/h5")
+    (synopsis "Interface to the HDF5 Library")
+    (description
+     "This package provides an S4 interface to the HDF5 library supporting
+fast storage and retrieval of R-objects like vectors, matrices and arrays to
+binary files in a language independent format.  The HDF5 format can therefore
+be used as an alternative to R's save/load mechanism.  Since h5 is able to
+access only subsets of stored data it can also handle data sets which do not
+fit into memory.")
+    (license license:bsd-2)))
+
 (define-public r-cgdsr
   (package
     (name "r-cgdsr")