summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2019-10-03 15:49:13 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 21:38:08 +0100
commit069554dc240078febab777c525a346594d02512e (patch)
tree4bd80c5c3fccf7db09e7795210f1d17bd9fdd9c0 /gnu/packages/cran.scm
parentae105119812bca8e9f2d74dcf11be95a293c0cc6 (diff)
downloadguix-069554dc240078febab777c525a346594d02512e.tar.gz
gnu: Add r-latex2exp.
* gnu/packages/cran.scm (r-latex2exp): new variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1e55606ef9..f56c3882c3 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20863,3 +20863,24 @@ explaining the meaning of @code{HTTP} status codes.  Functions are included for
 searching for codes by full or partial number, by message, and to get
 appropriate dog and cat images for many status codes.")
     (license license:expat)))
+
+(define-public r-latex2exp
+  (package
+    (name "r-latex2exp")
+    (version "0.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "latex2exp" version))
+              (sha256
+               (base32
+                "12nbcgfmv13k6sc6m326ras9bcvy380b7rxcxphn06r3cfkby0zw"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-stringr" ,r-stringr)
+       ("r-magrittr", r-magrittr)))
+    (home-page "https://github.com/stefano-meschiari/latex2exp/")
+    (synopsis "Use LaTeX expressions in plots")
+    (description "@code{latex2exp} parses and converts LaTeX math formulas to
+R's plotmath expressions, used to enter mathematical formulas and symbols to be
+rendered as text, axis labels, etc. throughout R's plotting system.")
+    (license license:expat)))