summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-12-08 20:22:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-12 18:39:26 +0100
commitc2d25c7b5ed1bdff7ba62e6f0981ce6f1eb53988 (patch)
treedee092392b8b93da5fd5c37f70abd1a89b5ededa /gnu/packages/cran.scm
parente0746ee4c4dab5b4bff9af4cb8b6256ef7888c42 (diff)
downloadguix-c2d25c7b5ed1bdff7ba62e6f0981ce6f1eb53988.tar.gz
gnu: Add r-rcppde.
* gnu/packages/cran.scm (r-rcppde): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 2eaeebb3ca..cb857e8232 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4638,6 +4638,27 @@ and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
 @code{citation(\"Rcpp\")} for details on these last two.")
     (license license:gpl2+)))
 
+(define-public r-rcppde
+  (package
+    (name "r-rcppde")
+    (version "0.1.6")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "RcppDE" version))
+              (sha256
+               (base32
+                "1i9jj595nqpb16y22z2b8fcf0gq1fg0pbiisbd837p1cyw4nff69"))))
+    (properties `((upstream-name . "RcppDE")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-rcpp r-rcpparmadillo))
+    (home-page "https://cran.r-project.org/package=RcppDE")
+    (synopsis "Global optimization by differential evolution in C++")
+    (description
+     "This package provides an iteration of the @code{DEoptim} function.  It
+performs global optimization by differential evolution.")
+    (license license:gpl2+)))
+
 (define-public r-rcppml
   (package
     (name "r-rcppml")