summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-07 12:48:40 +0200
commit17f3ec42ec1a4139ec87d968053de912ae2e200d (patch)
tree349f672a43ed1d884214cf7ba66f57deae1ce881 /gnu/packages/cran.scm
parentafb697c1146ffb2d0adb2125bc1007a624216d8c (diff)
downloadguix-17f3ec42ec1a4139ec87d968053de912ae2e200d.tar.gz
gnu: Add r-netrep.
* gnu/packages/cran.scm (r-netrep): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 73e3b760e5..03dcf1c396 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9470,6 +9470,37 @@ visualization and candidate genes around SNPs.")
 of precision-recall and ROC (Receiver Operator Characteristics) curves.")
     (license license:gpl3)))
 
+(define-public r-netrep
+  (package
+    (name "r-netrep")
+    (version "1.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "NetRep" version))
+       (sha256
+        (base32
+         "1swlb2k9bc7whvslxbklz864j9ynvna73hvq5rhv61cv5vy05ksd"))))
+    (properties `((upstream-name . "NetRep")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-abind" ,r-abind)
+       ("r-bh" ,r-bh)
+       ("r-foreach" ,r-foreach)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcpparmadillo" ,r-rcpparmadillo)
+       ("r-rhpcblasctl" ,r-rhpcblasctl)
+       ("r-statmod" ,r-statmod)))
+    (native-inputs `(("r-knitr" ,r-knitr)))
+    (home-page "https://cran.r-project.org/package=NetRep")
+    (synopsis "Permutation testing network module preservation across datasets")
+    (description
+     "This package provides functions for assessing the
+replication/preservation of a network module's topology across datasets
+through permutation testing.")
+    (license license:gpl2)))
+
 (define-public r-abcoptim
   (package
     (name "r-abcoptim")