summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-04 16:07:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-05 09:12:39 +0200
commit41ea9bed977d9974a0a48af9b19cd0254a9cc29d (patch)
tree20e6cf7d5729fae9c9463c63872e94f4bde0ef63 /gnu/packages/cran.scm
parentd5c08f11e1c17a10625d413b1aa7350218f61dfc (diff)
downloadguix-41ea9bed977d9974a0a48af9b19cd0254a9cc29d.tar.gz
gnu: Add r-ggnewscale.
* gnu/packages/cran.scm (r-ggnewscale): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index eee883a0c7..b3adc65195 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17700,6 +17700,27 @@ main plot at different sides (left, right, top and bottom) with axes exactly
 matched.")
     (license license:artistic2.0)))
 
+(define-public r-ggnewscale
+  (package
+    (name "r-ggnewscale")
+    (version "0.4.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggnewscale" version))
+       (sha256
+        (base32
+         "1hjysfagd2lqy8yivqq9q7l6hbvyq8kasw3zqh5fk9xn18ikc702"))))
+    (properties `((upstream-name . "ggnewscale")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)))
+    (home-page "https://cran.r-project.org/package=ggnewscale")
+    (synopsis "Multiple fill and color scales in ggplot2")
+    (description
+     "This package lets you use multiple fill and color scales in ggplot2.")
+    (license license:gpl3)))
+
 (define-public r-rex
   (package
     (name "r-rex")