summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-04 16:07:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-05 09:12:39 +0200
commitb71f21339ff0c9ded5f6dc3e15d0ea7ab55f6578 (patch)
tree9bf91655c6e03bf94ad729c956c3d5efedd347a0 /gnu/packages/cran.scm
parent41ea9bed977d9974a0a48af9b19cd0254a9cc29d (diff)
downloadguix-b71f21339ff0c9ded5f6dc3e15d0ea7ab55f6578.tar.gz
gnu: Add r-ggpointdensity.
* gnu/packages/cran.scm (r-ggpointdensity): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b3adc65195..cf24d0fb37 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17721,6 +17721,31 @@ matched.")
      "This package lets you use multiple fill and color scales in ggplot2.")
     (license license:gpl3)))
 
+(define-public r-ggpointdensity
+  (package
+    (name "r-ggpointdensity")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ggpointdensity" version))
+       (sha256
+        (base32
+         "0c9a14j3b0hvamqylhzldw2hjdxmfbllwahjkf3gg2rw337ld9iy"))))
+    (properties
+     `((upstream-name . "ggpointdensity")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ggplot2" ,r-ggplot2)))
+    (home-page "https://github.com/LKremer/ggpointdensity")
+    (synopsis "Cross between a 2D density plot and a scatter plot")
+    (description
+     "This package provides a cross between a 2D density plot and a scatter
+plot, implemented as a ggplot2 @code{geom}.  Points in the scatter plot are
+colored by the number of neighboring points.  This is useful to visualize the
+2D-distribution of points in case of overplotting.")
+    (license license:gpl3)))
+
 (define-public r-rex
   (package
     (name "r-rex")