summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2022-04-29 13:27:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-29 18:25:30 +0200
commitca831dfa09a50201c7588124d67e5c381406b396 (patch)
treeb99dbdad7db9164824995a283b519bf61b832ff3 /gnu/packages/cran.scm
parent325d53d5f634f6490e3291304fb5522400039224 (diff)
downloadguix-ca831dfa09a50201c7588124d67e5c381406b396.tar.gz
gnu: Add r-zlog.
* gnu/packages/cran.scm (r-zlog): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a673efcf73..91c54bac9a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6510,6 +6510,28 @@ right-hand side of an assignment into multiple values and assigns these values
 to variables on the left-hand side of the assignment.")
     (license license:expat)))
 
+(define-public r-zlog
+  (package
+    (name "r-zlog")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "zlog" version))
+              (sha256
+               (base32
+                "1d5j31p0h3rrn230087h3ngpvwknlisjv0f1qdbicdj9m177spci"))))
+    (properties `((upstream-name . "zlog")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://cran.r-project.org/package=zlog")
+    (synopsis "Transformation for laboratory easurements")
+    (description
+     "The @code{zlog} package offers functions to transform laboratory
+measurements into standardised z or @math{z(log)-values}.  Therefore the lower
+and upper reference limits are needed.  If these are not known they could be
+estimated from a given sample.")
+    (license license:gpl3+)))
+
 (define-public r-vctrs
   (package
     (name "r-vctrs")