summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 19:57:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 20:14:15 +0100
commit039aebabff5589d14ba2b333980a8508ca023052 (patch)
tree5f44d9b674e7781c544cebc776a296705f1cc612 /gnu/packages/cran.scm
parent3a3dd0552837b7c1c0082e3f8932b6a80bee5bc2 (diff)
downloadguix-039aebabff5589d14ba2b333980a8508ca023052.tar.gz
gnu: Add r-maxlik.
* gnu/packages/cran.scm (r-maxlik): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 151fc6a0ca..90d8e227ee 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -32343,6 +32343,29 @@ of a small set of carefully designed functions, most of which
 ")
     (license license:gpl3)))
 
+(define-public r-maxlik
+  (package
+    (name "r-maxlik")
+    (version "1.5-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "maxLik" version))
+       (sha256
+        (base32 "0pdigfpyiqacj2ydhpn5w1h89dz1ydk0syzs25lsgdi40sz0bvkw"))))
+    (properties `((upstream-name . "maxLik")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-generics r-misctools r-sandwich))
+    (home-page "https://cran.r-project.org/package=maxLik")
+    (synopsis "Maximum Likelihood Estimation and related tools")
+    (description
+     "This package provides functions for @dfn{Maximum Likelihood} (ML) estimation,
+non-linear optimization, and related tools.  It includes a unified way to call
+different optimizers, and classes and methods to handle the results from the
+Maximum Likelihood viewpoint.  It also includes a number of convenience tools
+for testing and developing your own models.")
+    (license license:gpl2+)))
+
 (define-public r-misctools
   (package
     (name "r-misctools")