summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 09:38:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 10:02:02 +0100
commit5ef7d057ed4791686ebc2c2649069cc54ca026c5 (patch)
treea0a1bab12a3f4943b06c1af6b287718ea3fa9083 /gnu/packages/cran.scm
parent601ddf02cc8ceb59c220b01bc7b1894de261f2e9 (diff)
downloadguix-5ef7d057ed4791686ebc2c2649069cc54ca026c5.tar.gz
gnu: Add r-snp-plotter.
* gnu/packages/cran.scm (r-snp-plotter): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d6a42ceea2..fca123f5b4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12388,3 +12388,28 @@ alleles, estimating and testing for Hardy-Weinberg disequilibrium, estimating
 and testing for linkage disequilibrium, ...")
     ;; Any GPL version.
     (license license:gpl2+)))
+
+(define-public r-snp-plotter
+  (package
+    (name "r-snp-plotter")
+    (version "0.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "snp.plotter" version))
+       (sha256
+        (base32
+         "16apsqvkah5l0d5qcwp3lq2jspkb6n62wzr0wskmj84jblx483vv"))))
+    (properties `((upstream-name . "snp.plotter")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-genetics" ,r-genetics)))
+    (home-page "https://cran.r-project.org/web/packages/snp.plotter/")
+    (synopsis "Plot p-values using single SNP and/or haplotype data")
+    (description
+     "This package helps you create plots of p-values using single SNP and/or
+haplotype data.  Main features of the package include options to display a
+@dfn{linkage disequilibrium} (LD) plot and the ability to plot multiple
+datasets simultaneously.  Plots can be created using global and/or individual
+haplotype p-values along with single SNP p-values.  Images are created as
+either PDF/EPS files.")
+    (license license:gpl2+)))