summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-10 14:04:22 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-11 15:44:41 +0100
commit6f4f04a82df20e9941d777dbed7bfe0a78b68e63 (patch)
treeaa969c631c100766af66da0e2d67159bbdd3ad30 /gnu/packages/cran.scm
parent4ba7aab96503aa8e4b450fca1e68ca79eef3a534 (diff)
downloadguix-6f4f04a82df20e9941d777dbed7bfe0a78b68e63.tar.gz
gnu: Add r-coro.
* gnu/packages/cran.scm (r-coro): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6338cb7853..8d4cb1c7b2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5014,6 +5014,31 @@ avoid overlapping text labels.  Labels repel away from each other and away
 from the data points.")
     (license license:gpl3)))
 
+(define-public r-coro
+  (package
+    (name "r-coro")
+    (version "1.0.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "coro" version))
+       (sha256
+        (base32 "14irld29dipgfd34y0k351daqg9vqpnpdx8m3pxmqr1aiyj5f5cv"))))
+    (properties `((upstream-name . "coro")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rlang))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/r-lib/coro")
+    (synopsis "Coroutines for R")
+    (description
+     "This package provides coroutines for R, a family of functions that can
+be suspended and resumed later on.  This includes async functions (which
+await) and generators (which yield).  Async functions are based on the
+concurrency framework of the @code{promises} package.  Generators are based on
+a dependency free iteration protocol defined in @code{coro} and are compatible
+with iterators from the @code{reticulate} package.")
+    (license license:expat)))
+
 (define-public r-corrplot
   (package
     (name "r-corrplot")