summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-24 23:26:48 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-24 23:44:12 +0100
commitdcc502865c6f1c88065747cc3daf63ceb1bdc796 (patch)
treef0a43749bad89f84740a69ba34b4e8ab9b57f5c6 /gnu/packages/cran.scm
parente5228273de3ff6601118bffb9aead3d20f006eff (diff)
downloadguix-dcc502865c6f1c88065747cc3daf63ceb1bdc796.tar.gz
gnu: Add r-deldir.
* gnu/packages/cran.scm (r-deldir): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 07d4bb08f2..2916bfa685 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12121,3 +12121,27 @@ distributions defined by the user.  It also contains functions for regression
 models, hierarchical models, Bayesian tests, and illustrations of Gibbs
 sampling.")
     (license license:gpl2+)))
+
+(define-public r-deldir
+  (package
+    (name "r-deldir")
+    (version "0.1-16")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "deldir" version))
+       (sha256
+        (base32
+         "0549kj0hlkdyvm5axsm3np30wg53fm2pxybijzw0avlgsd2y2n2q"))))
+    (build-system r-build-system)
+    (native-inputs `(("gfortran" ,gfortran)))
+    (home-page "https://cran.r-project.org/web/packages/deldir")
+    (synopsis "Delaunay triangulation and Dirichlet (Voronoi) tessellation")
+    (description
+     "This package provides tools for calculating the Delaunay triangulation
+and the Dirichlet or Voronoi tessellation (with respect to the entire plane)
+of a planar point set.  It plots triangulations and tessellations in various
+ways, clips tessellations to sub-windows, calculates perimeters of
+tessellations, and summarizes information about the tiles of the
+tessellation.")
+    (license license:gpl2+)))