summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-05 15:14:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-05 20:03:06 +0200
commit0fd7d59dc387eea437482f7584d03c5a20399faa (patch)
treef858965ddebafc376e395555e7a5cea4721c9968 /gnu/packages/cran.scm
parentaaed237d1bcae69bd3c65f06633a8a4c88f2e382 (diff)
downloadguix-0fd7d59dc387eea437482f7584d03c5a20399faa.tar.gz
gnu: Add r-moonbook.
* gnu/packages/cran.scm (r-moonbook): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4d6bd269b1..1025ff093a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4826,6 +4826,35 @@ tidyverse workflow.")
 hypothesis of normality.")
     (license license:gpl2+)))
 
+(define-public r-moonbook
+  (package
+    (name "r-moonbook")
+    (version "0.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "moonBook" version))
+       (sha256
+        (base32
+         "0hys56mwbm776ff7dibi8wzyf69qiais9rs1jazv79lk6h56s9s6"))))
+    (properties `((upstream-name . "moonBook")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-magrittr" ,r-magrittr)
+       ("r-nortest" ,r-nortest)
+       ("r-purrr" ,r-purrr)
+       ("r-sjmisc" ,r-sjmisc)
+       ("r-stringr" ,r-stringr)
+       ("r-survival" ,r-survival)))
+    (home-page "https://github.com/cardiomoon/moonBook")
+    (synopsis "Functions and datasets for the book by Keon-Woong Moon")
+    (description
+     "This package provides several analysis-related functions for the book
+entitled \"R statistics and graph for medical articles\" (written in Korean),
+version 1, by Keon-Woong Moon with Korean demographic data with several plot
+functions.")
+    (license license:gpl2)))
+
 (define-public r-writexl
   (package
     (name "r-writexl")