summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2020-02-04 14:10:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-02-22 20:42:12 +0100
commitfe0020609a2e6287b31aae1159cb11dfc9506ca2 (patch)
tree669d4c0430552273411e6bddb8c547b063d35d5d /gnu/packages/cran.scm
parent3be13aa8ca8044e7e77e142f7fab489044a06663 (diff)
downloadguix-fe0020609a2e6287b31aae1159cb11dfc9506ca2.tar.gz
gnu: Add r-kutils.
* gnu/packages/cran.scm (r-kutils): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 96f7fd034e..bda87d1a2d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19860,3 +19860,34 @@ multivariate statistical models.  It consists of a library of functions and
 optimizers that allow you to quickly and flexibly define an SEM model and
 estimate parameters given observed data.")
     (license license:asl2.0)))
+
+(define-public r-kutils
+  (package
+    (name "r-kutils")
+    (version "1.69")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "kutils" version))
+       (sha256
+        (base32
+         "12pg26a85h0jxlfcyai68dbh4bq1gnq8v1ngi8k9qvafbrpc6gx8"))))
+    (properties `((upstream-name . "kutils")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-foreign" ,r-foreign)
+       ("r-lavaan" ,r-lavaan)
+       ("r-openxlsx" ,r-openxlsx)
+       ("r-plyr" ,r-plyr)
+       ("r-runit" ,r-runit)
+       ("r-xtable" ,r-xtable)))
+    (home-page "https://cran.r-project.org/package=kutils")
+    (synopsis "Project management tools")
+    (description
+     "This package provides tools for data importation, recoding, and
+inspection.  There are functions to create new project folders, R code
+templates, create uniquely named output directories, and to quickly obtain a
+visual summary for each variable in a data frame.  The main feature here is
+the systematic implementation of the \"variable key\" framework for data
+importation and recoding.")
+    (license license:gpl2)))