summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-14 13:34:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:58 +0100
commit5c0b5b8ad7351a0d951ee2227093aacefdae28e4 (patch)
treef4a4c43fca7997b5a3bcaa00eb0be64a60d6330c /gnu/packages/cran.scm
parentc67508079d2abf9b286812c3b2889f4bbbcf2735 (diff)
downloadguix-5c0b5b8ad7351a0d951ee2227093aacefdae28e4.tar.gz
gnu: Add r-adamethods.
* gnu/packages/cran.scm (r-adamethods): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9e11802224..bbe44d60b8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -18625,3 +18625,33 @@ solutions to some commons problems related to Ergonomics and Anthropometry.
 They are based on clustering, the statistical concept of data depth,
 statistical shape analysis and archetypal analysis.")
     (license license:gpl2+)))
+
+(define-public r-adamethods
+  (package
+    (name "r-adamethods")
+    (version "1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "adamethods" version))
+       (sha256
+        (base32
+         "0mp73zh5x6h18gv29v981kb9n632kb58lvlcxwr6vcvrx393nrxh"))))
+    (properties `((upstream-name . "adamethods")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-anthropometry" ,r-anthropometry)
+       ("r-archetypes" ,r-archetypes)
+       ("r-fnn" ,r-fnn)
+       ("r-foreach" ,r-foreach)
+       ("r-nnls" ,r-nnls)
+       ("r-tolerance" ,r-tolerance)
+       ("r-univoutl" ,r-univoutl)))
+    (home-page "https://cran.r-project.org/web/packages/adamethods/")
+    (synopsis "Archetypoid algorithms and anomaly detection")
+    (description
+     "This package is a collection of several algorithms to obtain
+archetypoids with small and large databases and with both classical
+multivariate data and functional data (univariate and multivariate).  Some of
+these algorithms also allow to detect anomalies (outliers).")
+    (license license:gpl2+)))