summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-01 12:58:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-01 13:33:03 +0100
commit536a7ca2aaf7cf7bd386cca3d6ce4fa2eb43a025 (patch)
tree519a2dd165d88ade71fed07e61dcec0e5de8b53f /gnu/packages/cran.scm
parent7340ae0c6df6f2f79f8296f118ba82680c752399 (diff)
downloadguix-536a7ca2aaf7cf7bd386cca3d6ce4fa2eb43a025.tar.gz
gnu: Add r-adapsamp.
* gnu/packages/cran.scm (r-adapsamp): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 155c618472..6b88203859 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -19179,3 +19179,30 @@ organized into a directed acyclic graph.  It contains an interactive Shiny
 application @code{adaprApp()}.  It uses Git and file hashes to track version
 histories of inputs and outputs.")
     (license license:lgpl2.0)))
+
+(define-public r-adapsamp
+  (package
+    (name "r-adapsamp")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "AdapSamp" version))
+       (sha256
+        (base32
+         "1jayjrsiib2ij4rxxj59g71r3xhzl5yqh0lhi8k6cfy03i7dkvis"))))
+    (properties `((upstream-name . "AdapSamp")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-pracma" ,r-pracma)))
+    (home-page "https://cran.r-project.org/web/packages/AdapSamp/")
+    (synopsis "Adaptive sampling algorithms")
+    (description
+     "For distributions whose probability density functions are log-concave,
+the adaptive rejection sampling algorithm can be used to build envelope
+functions for sampling.  For others, the modified adaptive rejection sampling
+algorithm, the concave-convex adaptive rejection sampling algorithm, and the
+adaptive slice sampling algorithm can be used.  This R package mainly includes
+these four functions: @code{rARS()}, @code{rMARS()}, @code{rCCARS()}, and
+@code{rASS()}.  These functions can realize sampling based on the algorithms
+above.")
+    (license license:gpl2)))