summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-07 15:55:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-07 23:32:44 +0100
commit10e16fa93d09d72302a2c27d94b2975aa8f86174 (patch)
treeceba0186cd8e042f858d3126da770a9c2db74039 /gnu/packages/cran.scm
parent66c39102e51a6d5915161d29fd8641129520ee35 (diff)
downloadguix-10e16fa93d09d72302a2c27d94b2975aa8f86174.tar.gz
gnu: Add r-mice.
* gnu/packages/cran.scm (r-mice): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 609d6648e7..97efca3602 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1313,3 +1313,39 @@ Jaro-Winkler).  An implementation of soundex is provided as well.  Distances
 can be computed between character vectors while taking proper care of encoding
 or between integer vectors representing generic sequences.")
     (license license:gpl3+)))
+
+(define-public r-mice
+  (package
+    (name "r-mice")
+    (version "2.46.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "mice" version))
+       (sha256
+        (base32
+         "1gjvlk67zvgipfczsca8zqk97vg3sivv82hblsdwp14s7smhjcax"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lattice" ,r-lattice)
+       ("r-mass" ,r-mass)
+       ("r-nnet" ,r-nnet)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rpart" ,r-rpart)
+       ("r-survival" ,r-survival)))
+    (home-page "https://cran.r-project.org/web/packages/mice/")
+    (synopsis "Multivariate imputation by chained equations")
+    (description
+     "Multiple imputation using @dfn{Fully Conditional Specification} (FCS)
+implemented by the MICE algorithm as described in @url{Van Buuren and
+Groothuis-Oudshoorn (2011), http://doi.org/10.18637/jss.v045.i03}.  Each
+variable has its own imputation model.  Built-in imputation models are
+provided for continuous data (predictive mean matching, normal), binary
+data (logistic regression), unordered categorical data (polytomous logistic
+regression) and ordered categorical data (proportional odds).  MICE can also
+impute continuous two-level data (normal model, pan, second-level variables).
+Passive imputation can be used to maintain consistency between variables.
+Various diagnostic plots are available to inspect the quality of the
+imputations.")
+    ;; Any of these two versions.
+    (license (list license:gpl2 license:gpl3))))