summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-08-22 10:42:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-08-22 11:18:29 +0200
commit36b38bb4f3f4926431ae2a6d6ae79d5ad0d3d079 (patch)
treeb4da3c37a0819fc98d8c7582773954f4aefbdae5 /gnu/packages/cran.scm
parentca823a1600bf99e4ca83b17b8cf0586790c180ba (diff)
downloadguix-36b38bb4f3f4926431ae2a6d6ae79d5ad0d3d079.tar.gz
gnu: Add r-polylabelr.
* gnu/packages/cran.scm (r-polylabelr): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b2a55d871b..3d1fcc928d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1503,6 +1503,28 @@ qualitative palettes with many (20-30 or more) colors.  See Coombes and
 colleagues (2019) @url{https://doi:10.18637/jss.v090.c01}.")
     (license license:asl2.0)))
 
+(define-public r-polylabelr
+  (package
+    (name "r-polylabelr")
+    (version "0.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "polylabelr" version))
+              (sha256
+               (base32
+                "01b2v0l5g8nxwbd6nwqv8ahypgh6gfhd4qabg75brlj7z1iyfzf2"))))
+    (properties `((upstream-name . "polylabelr")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcpp))
+    (home-page "https://github.com/jolars/polylabelr")
+    (synopsis "Finding pole of inaccessibility (visual center) of a polygon")
+    (description
+     "This package provides a wrapper around the @code{C++} library @code{
+polylabel} from @code{Mapbox}, providing an efficient routine for finding the
+approximate pole of inaccessibility of a polygon, which usually serves as an
+excellent candidate for labeling of a polygon.")
+    (license license:expat)))
+
 (define-public r-poorman
   (package
     (name "r-poorman")