summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2020-04-27 10:11:21 +0200
committerRoel Janssen <roel@gnu.org>2020-04-27 10:11:21 +0200
commit8521d93854db773806824416be0fef6675ed3719 (patch)
tree0178d06c58ed628d296ea505f8d729f1e68d0817 /gnu/packages/cran.scm
parent9c63165d9ee33a7a7e9017d7a36f658b5c2c415c (diff)
downloadguix-8521d93854db773806824416be0fef6675ed3719.tar.gz
gnu: Add r-reordercluster.
* gnu/packages/cran.scm (r-reordercluster): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b918a4aa49..94ed889609 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -449,6 +449,27 @@ small, reproducible, and runnable examples on code-oriented websites or email.
 such as copy/paste from an R session.")
     (license license:expat)))
 
+(define-public r-reordercluster
+  (package
+   (name "r-reordercluster")
+   (version "1.0")
+   (source (origin
+            (method url-fetch)
+            (uri (cran-uri "ReorderCluster" version))
+            (sha256
+             (base32
+              "0ss750frzvj0bm1w7zblmcsjpszhnbffwlkaw31sm003lbx9hy58"))))
+   (build-system r-build-system)
+   (propagated-inputs
+    `(("r-gplots" ,r-gplots)
+      ("r-rcpp" ,r-rcpp)))
+   (home-page "https://cran.r-project.org/web/packages/ReorderCluster")
+   (synopsis "Reordering the dendrogram according to the class labels")
+   (description "This package provides tools for performing the leaf reordering
+for the dendrogram that preserves the hierarchical clustering result and at the
+same time tries to group instances from the same class together.")
+   (license license:gpl3+)))
+
 (define-public r-callr
   (package
     (name "r-callr")